Seven weeks - no website update

So, your CHL Application has been filed and the clock has slowed to a crawl - tell us about it!

Moderator: carlson1

Post Reply

Topic author
vmitche
Junior Member
Posts in topic: 1
Posts: 1
Joined: Thu Apr 26, 2018 10:05 am

Seven weeks - no website update

#1

Post by vmitche » Thu Apr 26, 2018 10:18 am

I submitted all documentation on March 8th, and received the confirmation hours later. The website has yet to show that my info has been received. I've called twice since then, and emailed twice as well. Never received a response via email, but both phone reps have confirmed all documentation has been received. It doesn't bother me if it takes the full 60 days to process, but I'd feel better if the website would reflect receipt of my info.

This happened once before: submitted everything Jan 9th, received confirmation email, and the website never updated. I admit I didn't call until March 8th, and the rep said my LTC-100 wasn't received, despite getting the confirmation email two months prior! So the wait time technically started on 3/8 once I re-uploaded my LTC-100. I'm just hoping this isn't happening again.

Has anyone else experienced this?


dogman197
Junior Member
Posts in topic: 1
Posts: 6
Joined: Sat Jun 02, 2018 12:51 am

Re: Seven weeks - no website update

#2

Post by dogman197 » Sat Jun 02, 2018 6:17 pm

Yep, DPS said I entered the LTC 100 and supporting information in the wrong place. Evidently the application and training/ supplements forms are two different animals to be sent in separately. They trashed everything but the application and fingerprints. I guess it’s not their department or job. I lost 30 days. Oh well, I’m 63, and waited for a lot in my life. A few more days wont hurt me.

Post Reply

Return to “The "Waiting Room"”